Inbound 1300 number calls failing
Incident Report for M.D.G. IT
Resolved
Our providers 1300 routing issues have been resolved, we are continuing to monitor this system closely
Posted about 1 month ago. Nov 08, 2018 - 11:04 AEDT
Investigating
Calls to 1300 023 123 are currently failing due to 1300 number routing issues at our provider. We will update this issue as soon as an ETA is available.
Posted about 1 month ago. Nov 08, 2018 - 10:52 AEDT
This incident affected: Phone Support.